__weak不能使用问题

问题描述:输入法加了一个新类库,报如下错误:

The current deployment target does not support automated __weak references

问题解决

ARC是从4.2以上版本开始支持的,但是不能使用__weak。

从5.0开始支持所有ARC。

在project->info->ios Deployment Target 将target版本改为5.0或者5.0以上。

发表评论

电子邮件地址不会被公开。 必填项已用*标注

此站点使用Akismet来减少垃圾评论。了解我们如何处理您的评论数据